Queens University - Microsoft Services - Slowness [m365 Online] – Incident details

All systems operational

Microsoft Services - Slowness [m365 Online]

Resolved
Degraded performance
Started over 1 year agoLasted about 10 hours

Affected

student services

Degraded performance from 12:46 PM to 10:19 PM

email / office 365

Degraded performance from 12:46 PM to 10:19 PM

Updates
  • Resolved
    Resolved

    From Microsoft.

    An unexpected usage spike resulted in Azure Front Door (AFD) and Azure Content Delivery Network (CDN) components performing below acceptable thresholds, leading to intermittent errors, timeout, and latency spikes. While the initial trigger event was a Distributed Denial-of-Service (DDoS) attack, which activated our DDoS protection mechanisms, initial investigations suggest that an error in the implementation of our defenses amplified the impact of the attack rather than mitigating it.

  • Monitoring
    Monitoring

    Connectivity issues or slowness within the M365 Online service, some users may also experience connectivity issues or slowness when using the Power Platform and Azure service.