Queens University - Microsoft Services - Service Degradation – Incident details

All systems operational

Microsoft Services - Service Degradation

Resolved
Operational
Started 11 months agoLasted 3 days

Affected

student services

Partial outage from 7:58 AM to 8:24 AM

email / office 365

Partial outage from 7:58 AM to 8:24 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Connectivity issues or slowness within the Microsoft 365 and Azure services, some users may experience connectivity issues or slowness when using Microsoft 365 apps and services such as Email, SharePoint and OneDrive.