Queens University - Microsoft Services [M365 Online] – Incident details

All systems operational

Microsoft Services [M365 Online]

Resolved
Operational
Started 7 days agoLasted 3 days

Affected

student services

Partial outage from 3:04 PM to 8:39 AM, Operational from 8:39 AM to 12:55 PM

email / office 365

Partial outage from 3:04 PM to 8:39 AM, Operational from 8:39 AM to 12:55 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Update
    UTC
    Update

    Microsoft has advised that service availability remains stable above 99%, with most users no longer experiencing issues. However, Apple Mail users may continue to experience connectivity problems.

    We will continue to monitor the situation and provide further updates as needed.

  • Update
    UTC
    Update

    Microsoft is implementing corrective actions and closely monitoring service health as recovery progresses. Investigation remains ongoing, and we will provide further updates as more information becomes available.

  • Monitoring
    UTC
    Monitoring

    Services are recovering, though some users may continue to experience intermittent issues - Microsoft are actively working to fully resolve the problem.

  • Identified
    UTC
    Identified

    Microsoft is currently investigating a service issue affecting multiple Microsoft 365 services, including:

    • OneDrive for Business

    • SharePoint Online

    • Exchange Online

    • Microsoft Teams

    • Microsoft Purview

    • Microsoft Defender XDR

    Users may experience degraded or intermittent functionality across these services.

    This is a Microsoft service issue being tracked under incident MO1465074.

    Microsoft is continuing to investigate, and we will provide further updates as more information becomes available.